月度归档: 2024 年 4 月

  • BWHVPS 美国大带宽VPS推荐CN2 GIA优化线路 最高10Gbps带宽

    BWHVPS 美国大带宽VPS推荐CN2 GIA优化线路 最高10Gbps带宽

    搬瓦工BWHVPS,一个2013年成立的老牌海外主机商,开始的时候有提供低价VPS主机,记得有低价至3.99美元一年。后来由于策略的调整,取消原本低价的产品,而以提供大带宽、CN2优化线路的且多机房的VPS主机产品。我们看到的很多美国VPS可能1Gbps带宽比较多见,有看到10Gbps带宽的美国VPS吗?

    在这里,BWHVPS服务商有提供最高可选10Gbps带宽的VPS,而且有10+数据中心可以自由后台面板切换更换。

    套餐核心内存硬盘流量带宽价格购买
    CN2 GIA-E2120GB1TB2.5Gbps$49.99/季度购买
    CN2 GIA-E3240GB2TB2.5Gbps$89.99/季度购买
    CN2 GIA-E4480GB3TB2.5Gbps$56.99/月购买
    CN2 GIA-E68160GB5TB5Gbps$86.99/月购买
    CN2 GIA-E816320GB8TB5Gbps$159.99/月购买
    CN2 GIA-E1032640GB10TB10Gbps$289.99/月购买
    CN2 GIA-E12641280GB12TB10Gbps$549.99/月购买

    我们可以看到最低2.5Gbps带宽,最高可选10G带宽,有多个机房可选。

    新购的时候只有3个机房可以选择,但是在购买后,其实可以在后台切换选择十多个机房。切换后IP地址会变化,但是数据会帮助我们迁移到新的机房,这样是不是可以实现多IP的更换。

    这样大带宽的VPS主机适合有下载、游戏、远程办公业务用途。

  • 更改 Windows VPS 上的 RDP 远程桌面端口 图文教程

    更改 Windows VPS 上的 RDP 远程桌面端口 图文教程

    一般Windows系统的VPS,您可能需要考虑将 RDP 端口更改为非标准端口。默认情况下,RDP 协议使用端口 3389,该端口通常会被暴力破解和/或扫描。更改 Windows Server 的 RDP 侦听端口是您可以采取的额外安全步骤。

    在本教程中,我们将介绍如何更改 Windows VPS 上的 RDP 端口。

    • 通过远程桌面连接客户端登录您的 Windows VPS。
    • 连接到 VPS 后,启动注册表编辑器。 (在搜索区域输入regedit)
    • 导航到以下注册表子项:HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
    • 查找端口号
    • 单击“编辑”>“修改” ,然后单击“小数” 
    • 键入您要将 RDP 端口更改为的新端口号,然后单击“确定” 
    • 关闭注册表编辑器
    • 在 Windows 防火墙设置中允许新端口号
    • 重新启动 Windows 服务器。

    服务器完成重新启动后,您会注意到服务器不再响应标准端口上的 RDP 连接,因此您现在需要在通过 RDP 连接时指定端口。例如,VPSIP:端口号

    您是否更改 Windows VPS 上的 RDP 端口?部署基于 Windows 的服务器时还采取哪些其他安全措施?在下面的评论部分留下您的反馈!

  • 2024-05-28搬瓦工限量版套餐补货通知:CN2 GIA-E 10G 限量版 $49.99/年

    2024-05-28搬瓦工限量版套餐补货通知:CN2 GIA-E 10G 限量版 $49.99/年

    时隔两个月左右,今天搬瓦工限量版套餐补货,CN2 GIA-E 10G 限量版套餐,价格是 $49.99/年,使用优惠码之后价格是 $46.6/年。这款限量版套餐是目前最便宜的 CN2 GIA-E 套餐,购买之后可以使用 DC6 CN2 GIA-E、DC9 CN2 GIA、日本大阪软银、荷兰联通等多个机房。

    • 2024-01-10:新年首次补货
    • 2024-01-30:今年再次补货!
    • 2024-02-20:今年再次补货!
    • 2024-03-18:今年再次补货!
    • 2024-03-31:今年再次补货!
    • 2024-04-23:今年再次补货!
    • 2024-05-21:今年再次补货!
    • 2024-05-28:今年再次补货!

    搬瓦工限量版补货详情

    下面是这次补货的搬瓦工限量版套餐,包括 CN2 GIA-E 10G 限量版。

    下面是 CN2 GIA LIMITED EDITION VPS 套餐截图。

    搬瓦工BWHVPS年付¥49.99云服务器
  • 外贸空间商推荐 WordPress主机专享 WordPress Hosting

    外贸空间商推荐 WordPress主机专享 WordPress Hosting

    我们选择外贸主机的时候是不是看到主机商的产品类型有包括 Shared Hosting、WordPress Hosting、WooCommerce Hosting这些种类?其中我们熟悉的是 Shared Hosting 类型的是通用的虚拟主机。实际上这些主机商大部分都是Linux主机产品,只是后两者是专门给 WordPress 站点提供的,而且有提供优化和内置的营销插件。

    如果我们有外贸网站且用的是 WordPress 程序的话,选择 WordPress 专用主机会更优势一些。如果是普通的其他程序的选择通用的虚拟主机会更好一些。那在这里,我们看到有3个可以适应用于 WordPress 专用主机的外贸空间商,如果有朋友需要选择的可以看看。

    SiteGround – 外贸专用主机推荐

    SiteGround,已经有超过20年的美国主机商,多年被WordPress评为优秀的主机商之一。服务商有提供Web Hosting、WordPress Hosting、企业邮局服务。数据中心涵盖新加坡、美国、欧洲等十多个机房,适合外贸业务用途。

    SiteGround 服务商提供的主机均是 Linux 系统的,如果是 WordPress 程序架设网站的话可以选择 WordPress Hosting,且如果是商务电商网点功能的,可以选择 WooCommerce Hosting 主机方案。每个主机赠送域名、自动备份、WordPress 自动建站安装和升级以及优化内置组件服务。

    官网地址www.siteground.com

    推荐理由:多年优秀海外主机商,支持30天免费退款。

    Hostinger  – 超过20年的老牌主机商

    Hostinger,这个主机商给我印象深刻的是早年才开始接触海外主机的时候主机商有提供免费主机。如今商家估计开始开窍要正式运营的,有提供全球100+的本土化运营,我们可以在左上角语言选择熟悉的语言版本接地气的本土化运营。当然主机产品都是一样的,提供虚拟主机、云主机、独立服务器等。

    我们可以看到上图,Hostinger 有提供自托管的 WordPress 主机和商务主机产品。赠送免费域名、CDN、免费电子邮箱、一键安装WordPress、免费网站迁移服务、WordPress安全检查和扫描服务、WordPress加速优化等,满足搜索引擎的SEO。

    官网地址www.hostinger.com

    推荐理由:多机房可选,购买之后选择机房,包括欧洲和美洲。

  • Debian12 putty无法使用ssh密钥登陆 解决办法 图文教程

    Debian12 putty无法使用ssh密钥登陆 解决办法 图文教程

    putty是比较简洁方便的ssh登陆工具,使用ssh密钥登陆快捷高效,不需输入密码登陆,网上有很多putty ssh登陆debian等系统的设置操作方法,但有个坑必须提醒一下大家。在debian11升级debian12版后出现无法使用putty登陆,一直提示server refused our key,原因和解决办法如下。

    原因

    Linux系统使用OpenSSh8.0版本以上后,/etc/sshd/sshd_config配置文件未默认添加ssh-rsa密钥认证,debian12采用的openssh为9.0版本以上,未默认添加ssh-rsa密钥认证。

    解决办法

    在/etc/sshd/sshd_config中添加PubkeyAcceptedKeyTypes +ssh-rsa,如下图所示。

    然后#systemctl restart sshd,重启ssh服务即可。

    如上述方法仍不能解决,请查看是否存在其他问题,例如authorized_keys文件中密钥是否正确、authorized_keys文件是否在/root/.ssh/目录下、/root/.ssh目录的权限是否为700、authorized_keys文件的权限是否为600或者640等。

  • 搬瓦工BWHVPS新增DC9套餐 768MB内存 1.5Gbps端口 年付$38美金

    搬瓦工BWHVPS新增DC9套餐 768MB内存 1.5Gbps端口 年付$38美金

    对于BWHVPS主机商我们是熟悉的,尤其是其中洛杉矶DC6和DC9机房有提供CN2 GIA优化线路,而且商家有提供最高10Gbps 带宽的CN2 GIA-E企业级带宽一般服务商还真没有。这次可能考虑到基础套餐的价格比较贵,看到有新增一个微小版本的DC9套餐,1.5Gbps带宽配置的。

    对于主机套餐的线路还是熟悉的,采用的是三网CN2 GIA线路。DC9 CN2 GIA机房。DC9机房的CN2 GIA对电信比较友好。

    The DC9 Plan1核768MB15GB768GB1.5G1$38/年购买

    可以叠加优惠码:BWHCCNCXVV,再优惠几美元。

  • PHP7兼容mysql_connect函数的方法 图文教程

    PHP7兼容mysql_connect函数的方法 图文教程

    php从7.0开始移除了mysql_connect这个函数

    Warning

    This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide. Alternatives to this function include:

    • mysqli_connect()
    • PDO::__construct()

    那么我们以前的老程序如何兼容,这里我们提供一个思路。

    //$dbhost = DATA_HOST;
    $dbport = 3306;
    //$dbuser = DATA_USERNAME;
    //$dbpass = DATA_PASSWORD;
    //$dbname = DATA_NAME;
    if(!function_exists('mysql_connect')){
        function mysql_connect($dbhost, $dbuser, $dbpass){
            global $dbport;
            global $dbname;
            global $mysqli;
            $mysqli = mysqli_connect("$dbhost:$dbport", $dbuser, $dbpass, $dbname);
            return $mysqli;
            }
        function mysql_select_db($dbname){
            global $mysqli;
            return mysqli_select_db($mysqli,$dbname);
            }
        function mysql_set_charset($character)
        {
            global $mysqli;
            return mysqli_query($mysqli, "set names {$character}");
        }
        function mysql_fetch_array($result){
            return mysqli_fetch_array($result);
            }
        function mysql_fetch_assoc($result){
            return mysqli_fetch_assoc($result);
            }
        function mysql_fetch_row($result){
            return mysqli_fetch_row($result);
            }
        function mysql_query($query){
            global $mysqli;
            return mysqli_query($mysqli,$query);
            }
        function mysql_escape_string($data){
            global $mysqli;
            return mysqli_real_escape_string($mysqli, $data);
            }
        function mysql_real_escape_string($data){
            return mysql_real_escape_string($data);
            }
        function mysql_close(){
            global $mysqli;
            return mysqli_close($mysqli);
            }
        function mysql_error(){
    		global $mysqli;
    		return mysqli_connect_error();
    	}
        function mysql_num_rows($data){
    		global $mysqli;
    		return mysqli_num_rows($data);
    	}
        function mysql_affected_rows(){
    		global $mysqli;
    		return mysqli_affected_rows($mysqli);
    	}
    }

    仅供参考,小伙伴们根据自己实际情况修改。

  • RAKSmart 云服务器低至年付19.9美元 香港 美国 德国等机房可选

    RAKSmart 云服务器低至年付19.9美元 香港 美国 德国等机房可选

    RAKSmart 云服务商其实也挺能折腾的,从原来的圣何塞机房扩展到洛杉矶、香港、韩国、日本,以及新增加还有德国法兰克福机房。云服务产品包括云服务器、VPS主机、物理独立服务器、裸机云服务器、高防服务器、大带宽服务器等。而且时不时还有一些促销,比如有这次开年有发布云服务器和VPS低价年付19.9美元。

    在这里,我们可以看到RAKSmart服务商提供的特价云服务器和特价VPS主机,年付低至19.9美元,有多个美国、欧洲、香港等机房可选,且可以安装 Win 和 Linux 系统,适合有需要低价VPS用户需求。

    机房核心内存硬盘带宽年付购买
    圣何塞2核1.5G35G HDD5M优化$19.9链接
    香港2核1.5G35G HDD5M优化$19.9链接
    法兰克福2核2G35G HDD10M国际$19.9链接
    圣何塞1核2G40G SSD1M优化$19.9链接
    香港1核2G40G SSD1M优化$19.9链接
    法兰克福1核2G40G SSD1M优化$19.9链接

    我们可以看到上面3个套餐仅有可以选择 Linux 系统,后三个方案是可以选择Linux和Win系统的。

    如果我们有需要低价年付VPS和云服务器可以试试。

  • CloudCone 优惠盘点 便宜美国VPS 年付$10+美元

    CloudCone 优惠盘点 便宜美国VPS 年付$10+美元

    CloudCone,一家2013年成立的海外主机商至今也有将近10年。商家从开始有提供单一洛杉矶MC机房的弹性VPS云服务器起步,目前也有包括云服务器、独立服务器、企业邮局、CDN等多个云生态产品,其中不定期也会有年付VPS和云服务器的活动,有低至年付10美元起步。

    CloudCone 商家云服务器VPS采用弹性技术,我们可以根据需要删除和重开机器,这个和我们熟悉的Linode、Vultr等服务商相似,这个比较灵活。唯一的缺点就是机房过于少,如果后续有增加多机房,那会好很多。

    CloudCone 不定期的也会发布年付和福利套餐,这里我们也不定期整理更新。

    以下表格计价单位均为美元

    复活节促销活动

    内存核心硬盘流量价格购买
    1G1核55G3T/月$16.3/年链接
    2G2核150G4T/月$28.5/年链接
    4G4核200G6T/月$52.52/年链接

    新年便宜VPS套餐

    采用KVM架构,硬盘为带SSD缓存HDD,1G口带宽,默认1个ipv4,3个ipv6,机房位于洛杉矶MC机房。有免费的自动快照,自动备份,防火墙托管等等。

    内存CPU硬盘流量价格选择
    0.5G1核20G2T/月$10.99/年链接
    1G2核40G3T/月$16.8/年链接
    2G2核80G3T/月$29.26/年链接
    3G2核110G4T/月$41.44/年链接
    4G4核180G5T/月$53.81/年链接
    8G4核280G10T/月$101.75/年链接
    16G8核570G10T/月$199/年链接

    大硬盘便宜VPS套餐

    这是以前有发布过的套餐,有部分套餐依旧是可以选择的。1G带宽,硬盘比之前会大一些。

    内存CPU硬盘流量价格选择
    1G2核40G3T/月$16.79/年链接
    2G2核100G6T/月$29.25/年链接
    4G3核200G8T/月$54.53/年链接
    8G4核400G8T/月$104.99/年链接
    16G8核900G10T/月$210/年链接
    32G16核2000G10T/月$390/年链接

    特价云服务器套餐

    CloudCone 商家也有提供云服务器和独立服务器,相比从技术角度和稳定性云服务器会更好一些。这里有部分云服务器套餐。

    内存CPUSSD流量价格选择
    1G1核20G3T/月$32.94/年链接
    2G2核40G6T/月$59.10/年链接
    4G3核80G8T/月$104.99/年链接
    8G4核160G8T/月$199.09/年链接
    16G8核300G10T/月$398.37/年链接
    32G16核600G10T/月$750.49/年链接

    如果有需要,我们也可以测试洛杉矶MC机房的IP:173.82.220.148。

  • 腾讯云 轻量 2核2G4M年付仅需¥99 MySQL 1核1G年付仅需¥59 续费与新购同价 2024年4月促销整理

    腾讯云 轻量 2核2G4M年付仅需¥99 MySQL 1核1G年付仅需¥59 续费与新购同价 2024年4月促销整理

    自从年前阿里云年付¥99推出以来,腾讯云也跟进了相关的个人¥99,企业¥199的轻量云套餐,同样的数据库低至年付¥59。

    我们这里整理了腾讯云2024年4月值得关注购买的轻量及mysql品类等。

    续费与新购同价

    轻量 2核2G4M

    • 提供通用计算性能和网络流量,适合小型网站、小程序和Web开发场景
    • 50GB SSD盘 300GB月流量 4M带宽

    ¥99/年

    MySQL 1核1G

    • 基础版架构,适用于个人学习,小型网站/应用,开发测试
    • 1核1G 20G SSD云硬盘

    ¥59/年

    以及众多的活动:

  • AWS云服务器Bitnami套件安装WordPress更新php版本到7.4.33 图文教程

    AWS云服务器Bitnami套件安装WordPress更新php版本到7.4.33 图文教程

    今日有小伙伴找到老季,说想要把aws云ec2服务器WordPress网站环境从php7.3升级到php7.4的版本,我们这里也记录一下这个的更新过程。

    服务器情况

    无法连接aws的ec2服务器

    登录上aws也经历了一些波折,发现登录服务器,老是无法连接。要不就是卡住了一样。之后就没有反应了。

    要么就是提示:

    ———-ERROR——- Unable to start command: invalid uid and gid

    毫无办法,按理来说aws不可能会有这种,控制台都无法连接ec2服务器的问题。之后我们终于查到了问题,由于系统安装的是ubuntu,所以我们用终端连接时,需要使用ubuntu用户进行连接,具体如下图所示:

    Run As : ubuntu

    这就是重点了,如果是centos、debian等发型版用root即可。

    之后重新使用”会话管理器”菜单就可以连接了。

    已安装的环境bitnami套件

    登录上服务器,发现服务器使用的是/opt/bitnami/ctlscript.sh命令,所以断定是bitnami的套件,而官网并没有给出详细的套件,这里我们只能自己编译了。

    编译php7.4.33

    安装必要的环境包

    请先直接切换到root用户,然后使用如下命令进行批量下载并安装必要的包

    sudo su   //直接回车
    wget https://www.php.net/distributions/php-7.4.33.tar.gz
    tar -xvf php-7.4.33.tar.gz
    apt-get update
    apt-get install -y libxml2-dev libssl-dev libcurl4-openssl-dev libpng-dev libjpeg-dev libfreetype6-dev zlib1g-dev libzip-dev libsqlite3-dev libonig-dev

    No package ‘libxml-2.0’ found

    hecking for libxml-2.0 >= 2.7.6… no configure: error: Package requirements (libxml-2.0 >= 2.7.6) were not met: No package ‘libxml-2.0’ found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables LIBXML_CFLAGS and LIBXML_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.

    但我们已经安装了libxml而且是最新的版本,在终端中指定一下路径:

    export PKG_CONFIG_PATH=/usr/lib/x86_64-linux-gnu/pkgconfig
    

    No package ‘sqlite3’ found

    configure: error: Package requirements (sqlite3 > 3.7.4) were not met: No package ‘sqlite3’ found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables SQLITE_CFLAGS and SQLITE_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.

    apt-get install libsqlite3-dev

    No package ‘oniguruma’ found

    configure: error: Package requirements (oniguruma) were not met: No package ‘oniguruma’ found Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix. Alternatively, you may set the environment variables ONIG_CFLAGS and ONIG_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.

    apt-get install libonig-dev

    配置PHP

    cd php-7.4.33
    ./configure --prefix=/usr/local/php7 --with-config-file-path=/usr/local/php7/etc --enable-mbstring --with-curl --with-openssl --with-zlib --enable-fpm --with-fpm-user=www-data --with-fpm-group=www-data --enable-opcache --enable-xml --enable-intl --with-gd --with-jpeg --with-freetype --with-mysqli --with-pdo-mysql

    Your PHP installation appears to be missing the MySQL extension which is required by WordPress.

    一开始出现了Your PHP installation appears to be missing the MySQL extension which is required by WordPress.错误,是我们没有带上mysql的扩展--with-mysqli --with-pdo-mysql,以上编译时,我们已经带上了。

    编译和安装PHP7.4.33

    make
    sudo make install
    

    配置php.ini

    sudo cp php.ini-development /usr/local/php7/etc/php.ini

    编辑 /usr/local/php7/etc/php.ini

    找到mysqli.default_socketpdo_mysql.default_socket的配置区,将其设置成/opt/bitnami/mysql/tmp/mysql.sock

    mysqli.default_socket = "/opt/bitnami/mysql/tmp/mysql.sock"
    
    pdo_mysql.default_socket = "/opt/bitnami/mysql/tmp/mysql.sock"
    

    如不配置则会出现:Error establishing a database connection

    导致WordPress的运行php环境找不到mysql的链接方法

    配置php-fpm.conf

    编辑/usr/local/php7/etc/php-fpm.conf文件

    sudo vi /usr/local/php7/etc/php-fpm.conf

    内容如下:

    [global]
    pid = /run/php-fpm.pid
    error_log = /var/log/php-fpm/error.log
    [my_pool]
    user = daemon
    group = daemon
    ;listen = 127.0.0.1:9000
    listen = /var/run/php-fpm.sock
    listen.owner = daemon
    listen.group = daemon
    pm = dynamic
    pm.start_servers = 5
    pm.min_spare_servers = 2
    pm.max_spare_servers = 8
    pm.max_children = 12

    这里我们使用的用户及用户组都是daemon跟bitnami套件中apache设置的是一样的权限。

    检查一下/var/run/这个目录是否存在,不存在则需要创建。

    启动php-fpm

    /usr/local/php7/sbin/php-fpm

    可以通过 ps aux | grep php-fpm 命令查看我们的php是否允许成功

    如果有/usr/local/php7/etc/php-fpm.conf的配置在运行说明已成功。

    配置apache2

    修改/opt/bitnami/apache2/conf/php-fpm-apache.conf,修改前记得备份!!!

    修改配置前请确保:/usr/local/php7/etc/php-fpm.conf的php-fpm已在运行。

    /opt/bitnami/apache2/conf/php-fpm-apache.conf改为以下内容

    <IfDefine USE_PHP_FPM>
      <Proxy "unix:/var/run/php-fpm.sock|fcgi://www-fpm" timeout=300>
      </Proxy>
      <FilesMatch \.php$>
        <If "-f %{REQUEST_FILENAME}">
          SetHandler "proxy:fcgi://www-fpm"
        </If>
      </FilesMatch>
    </IfDefine>

    此处Proxy需要跟上面的php-fpm.conf配置的listen一致,否则apache2无法链接到php-fpm。

    重启bitnami的apache服务

    /opt/bitnami/ctlscript.sh restart apache
    

    检查php版本是否成功

    我们在网站目录中新建一个info.php内容如下

    <?php phpinfo();
    

    之后通过网址打开 http://域名/info.php 检查一下,php版本是否是7.4.33

    错误日志

    我们的配置过程中出现了一些未知错误,还好有日志可以查询,下面我们指一下日志位置,有需要的小伙伴可能会用到。

    tail -n 20 /opt/bitnami/apache2/logs/error_log

    至此,教程结束,可能不算十分完整,但大概过程就是这样的。请小伙伴们指正~

WeChat