apache提示Failed loading ZendLoader.dll解决方法


在折腾upupw时,发现不管我怎么配置,apache总会提示“Failed loading…ZendLoader.dll”,就是说ZendLoader很悲催的没有被加载。(Zend Optimizer适用于php 5.2.x,5.3以上就变成Zend Loader了,其实还是这货)

后来无意间去Zend的论坛晃悠,发现有哥们和我的问题一样。

一句话:Windows下,Zend Loader only works with NTS !

就是说,这悲催的货只支持NTS版的php,TS版的不支持,所以遇到此问题的朋友可以检查一下php的版本。

附上NTS和TS的区别

NTS:Non Thread Safe

非安全线程, 在执行时不进行线程(Thread)安全检查。

TS:Thread Safe

安全线程, 执行时会进行线程(Thread)安全检查,以防止有新要求就启动新线程的CGI执行方式而耗尽系统资源。

在phpinfo中可以查看 Thread Safety 一项来检查NTS或TS。

点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注

Scroll Up